Scouter client JVM error after macOS BigSur update

Problem

: After updating to Big Sur, the following error occurs indicating that a JVM cannot be created

Cause

  • When updating to Big Sur, Java is installed by default

    • The issue appears to be caused by a mismatch between the Java version that Scouter points to and the Java version configured in Big Sur

Solution

: Resolved by specifying the installed JDK path in the scouter.client.app/Contents/Eclipse/scouter.ini file

-vm
/Library/Java/JavaVirtualMachines/jdk1.8.0_271.jdk/Contents/Home/bin/java

Reference

: https://github.com/scouter-project/scouter/issues/764arrow-up-right

Last updated